From 9b30301efee6ccb1270284ee7eea99151f87e6f4 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Mon, 19 Sep 2022 12:54:40 +0300
Subject: gnu: python-websockets: Extend test timeout.

* gnu/packages/python-web.scm (python-websockets)[arguments]: Add phase
to extend the tests timeout so slower machines can complete them.
---
 gnu/packages/python-web.scm | 6 ++++++
 1 file changed, 6 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 255c5d67ec..41a72089ec 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5671,6 +5671,12 @@ files.")
         (base32
          "1vk7g5z977mi89hamwiqawpmibwvv9ghrf3pqva1waxmyc7gyjb5"))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'extend-test-timeout
+                 (lambda _
+                   (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))
     (home-page "https://github.com/aaugustin/websockets")
     (synopsis
      "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")
-- 
cgit 1.4.1