From a145d7e9af6452f3514ab130db534e4592a9c2b9 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 1 Apr 2018 07:48:34 +0200
Subject: gnu: python-clf: Use INVOKE.

* gnu/packages/web.scm (python-clf)[arguments]: Substitute INVOKE for
SYSTEM*.
---
 gnu/packages/web.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)

(limited to 'gnu')

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0be62ac12c..36757ba8f9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5305,14 +5305,15 @@ internetarchive python module for programatic access to archive.org.")
          (modify-phases %standard-phases
            (add-after 'unpack 'get-tests
              (lambda _
-               (copy-file (assoc-ref %build-inputs "test-clf") "test_clf.py")))
+               (copy-file (assoc-ref %build-inputs "test-clf") "test_clf.py")
+               #t))
            (replace 'check
              (lambda _
-               (zero? (system* "nosetests"
-                               ;; These tests require internet connection
-                               "--exclude=test_browse"
-                               "--exclude=test_command"
-                               "--exclude=test_search")))))))
+               (invoke "nosetests"
+                       ;; These tests require an Internet connection.
+                       "--exclude=test_browse"
+                       "--exclude=test_command"
+                       "--exclude=test_search"))))))
       (home-page "https://github.com/ncrocfer/clf")
       (synopsis "Search code snippets on @url{https://commandlinefu.com}")
       (description "@code{clf} is a command line tool for searching code
-- 
cgit 1.4.1