From cab88488e937e677d1b0aef39a5ca926a54eced2 Mon Sep 17 00:00:00 2001
From: Eric Bavier <bavier@member.fsf.org>
Date: Thu, 5 Mar 2015 15:55:37 -0600
Subject: gnu: Add Text-Glob.

* gnu/packages/perl.scm (perl-text-glob): New variable.
---
 gnu/packages/perl.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fd5a0e6b37..caa129264b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -938,6 +938,26 @@ hooking into done_testing as well as via an END block.  You can declare a
 plan, or not, and things will still Just Work.")
     (license (package-license perl))))
 
+(define-public perl-text-glob
+  (package
+    (name "perl-text-glob")
+    (version "0.09")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RC/RCLAMP/"
+                           "Text-Glob-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0lr76wrsj8wcxrq4wi8z1640w4dmdbkznp06q744rg3g0bd238d5"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Text-Glob")
+    (synopsis "Match globbing patterns against text")
+    (description "Text::Glob implements glob(3) style matching that can be
+used to match against text, rather than fetching names from a filesystem.  If
+you want to do full file globbing use the File::Glob module instead.")
+    (license (package-license perl))))
+
 (define-public perl-try-tiny
   (package
     (name "perl-try-tiny")
-- 
cgit 1.4.1