Some GLib tests expect desktop things, such as an xterm, a MIME
database, the `update-desktop-database' program, which we don't provide.

--- glib-2.37.1/gio/tests/appinfo.c	2013-06-07 23:44:44.000000000 +0200
+++ glib-2.37.1/gio/tests/appinfo.c	2013-06-07 23:44:56.000000000 +0200
@@ -497,16 +497,10 @@ main (int argc, char *argv[])
 
   g_test_add_func ("/appinfo/basic", test_basic);
   g_test_add_func ("/appinfo/text", test_text);
-  g_test_add_func ("/appinfo/launch", test_launch);
   g_test_add_func ("/appinfo/show-in", test_show_in);
   g_test_add_func ("/appinfo/commandline", test_commandline);
-  g_test_add_func ("/appinfo/launch-context", test_launch_context);
-  g_test_add_func ("/appinfo/launch-context-signals", test_launch_context_signals);
   g_test_add_func ("/appinfo/tryexec", test_tryexec);
-  g_test_add_func ("/appinfo/associations", test_associations);
   g_test_add_func ("/appinfo/environment", test_environment);
-  g_test_add_func ("/appinfo/startup-wm-class", test_startup_wm_class);
-  g_test_add_func ("/appinfo/supported-types", test_supported_types);
   g_test_add_func ("/appinfo/from-keyfile", test_from_keyfile);
 
   return g_test_run ();

--- glib-2.34.3/gio/tests/contenttype.c	2013-01-16 21:22:29.000000000 +0100
+++ glib-2.34.3/gio/tests/contenttype.c	2013-01-16 21:22:33.000000000 +0100
@@ -207,13 +207,6 @@ main (int argc, char *argv[])
 
   g_test_init (&argc, &argv, NULL);
 
-  g_test_add_func ("/contenttype/guess", test_guess);
-  g_test_add_func ("/contenttype/unknown", test_unknown);
-  g_test_add_func ("/contenttype/subtype", test_subtype);
-  g_test_add_func ("/contenttype/list", test_list);
-  g_test_add_func ("/contenttype/executable", test_executable);
-  g_test_add_func ("/contenttype/description", test_description);
-  g_test_add_func ("/contenttype/icon", test_icon);
 
   return g_test_run ();
 }

--- glib-2.37.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:28.000000000 +0200
+++ glib-2.37.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:32.000000000 +0200
@@ -385,6 +385,7 @@ main (int   argc,
   g_setenv ("XDG_DATA_HOME", basedir, TRUE);
   cleanup_subdirs (basedir);
   
+  return 0;
   g_test_add_func ("/desktop-app-info/delete", test_delete);
   g_test_add_func ("/desktop-app-info/default", test_default);
   g_test_add_func ("/desktop-app-info/fallback", test_fallback);


-----------------------------
The hunk below removes tests that depend on `gdbus-testserver.py',
because that script depends on python-gobject.

--- glib-2.34.3/gio/tests/Makefile.in	2012-11-26 20:08:54.000000000 +0100
+++ glib-2.34.3/gio/tests/Makefile.in	2013-01-17 23:09:44.000000000 +0100
@@ -60,15 +60,8 @@ DIST_COMMON = $(srcdir)/Makefile.am $(sr
 noinst_PROGRAMS = $(am__EXEEXT_6) $(am__EXEEXT_8)
 @HAVE_DBUS_DAEMON_TRUE@am__append_1 = \
 @HAVE_DBUS_DAEMON_TRUE@	actions 		\
-@HAVE_DBUS_DAEMON_TRUE@	gdbus-connection	\
-@HAVE_DBUS_DAEMON_TRUE@	gdbus-connection-loss	\
-@HAVE_DBUS_DAEMON_TRUE@	gdbus-connection-slow	\
 @HAVE_DBUS_DAEMON_TRUE@	gdbus-names		\
-@HAVE_DBUS_DAEMON_TRUE@	gdbus-proxy		\
 @HAVE_DBUS_DAEMON_TRUE@	gdbus-proxy-threads	\
-@HAVE_DBUS_DAEMON_TRUE@	gdbus-proxy-well-known-name \
-@HAVE_DBUS_DAEMON_TRUE@	gdbus-introspection	\
-@HAVE_DBUS_DAEMON_TRUE@	gdbus-threading		\
 @HAVE_DBUS_DAEMON_TRUE@	gdbus-export		\
 @HAVE_DBUS_DAEMON_TRUE@	gdbus-error		\
 @HAVE_DBUS_DAEMON_TRUE@	gdbus-bz627724		\


The test below depends on the availability /etc/passwd to dbus-daemon.

--- glib-2.34.3/gio/tests/gdbus-auth.c	2013-01-19 14:32:14.000000000 +0100
+++ glib-2.34.3/gio/tests/gdbus-auth.c	2013-01-19 14:32:20.000000000 +0100
@@ -264,6 +264,7 @@ main (int   argc,
 {
   gint ret;
 
+  return 0;
   setlocale (LC_ALL, "C");
 
   g_type_init ();