about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Mattavelli <andreamattavelli@users.noreply.github.com>2017-04-03 22:28:34 +0100
committerGitHub <noreply@github.com>2017-04-03 22:28:34 +0100
commit0c95b3ec029d467be1a1b03eca125c0506877201 (patch)
tree6bcbfcc350702282e1e956794f3d32d62e7aa0d6 /CMakeLists.txt
parent2a2e972e8d287e61ad40b1cc14165b5eff482fc4 (diff)
parent6a70f100c67ce9a0c2cd52d4af8fb9a7cfce22e2 (diff)
downloadklee-0c95b3ec029d467be1a1b03eca125c0506877201.tar.gz
Merge pull request #636 from delcypher/cmake_bitcode_build_system_fixes
[CMake] bitcode build system fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 97c51a2e..ff55ad23 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,6 +64,13 @@ else()
   set(ADD_CUSTOM_COMMAND_USES_TERMINAL_ARG "")
 endif()
 
+if (("${CMAKE_VERSION}" VERSION_EQUAL "3.4") OR ("${CMAKE_VERSION}" VERSION_GREATER "3.4"))
+  # In CMake >= 3.4 ExternalProject_Add_Step() supports a `USES_TERMINAL` argument
+  set(EXTERNAL_PROJECT_ADD_STEP_USES_TERMINAL_ARG "USES_TERMINAL" "1")
+else()
+  set(EXTERNAL_PROJECT_ADD_STEP_USES_TERMINAL_ARG "")
+endif()
+
 ################################################################################
 # Sanity check - Disallow building in source.
 # Otherwise we would overwrite the Makefiles of the old build system.