about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Liew <daniel.liew@imperial.ac.uk>2016-11-23 12:45:47 +0000
committerDan Liew <delcypher@gmail.com>2016-11-23 15:07:45 +0000
commit79eb80725aeb8710bead7ed98dc139113f018da6 (patch)
treeafa8f4b609438671f04aaeaec2fd4c544188b131 /CMakeLists.txt
parentc003a21a8fc1849e3661d6b7b996a26ae8edaea8 (diff)
downloadklee-79eb80725aeb8710bead7ed98dc139113f018da6.tar.gz
[CMake] Fix bug where the wrong path is checked for when checking
to see if we can find klee-uclibc's C library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 310d43a1..4d75ab10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -578,7 +578,7 @@ if (ENABLE_KLEE_UCLIBC)
   # Find the C library bitcode archive
   set(KLEE_UCLIBC_BCA_NAME "klee-uclibc.bca")
   set(KLEE_UCLIBC_C_BCA "${KLEE_UCLIBC_PATH}/lib/libc.a")
-  if (NOT EXISTS "${KLEE_UCLIBC_PATH}")
+  if (NOT EXISTS "${KLEE_UCLIBC_C_BCA}")
     message(FATAL_ERROR
       "klee-uclibc library not found at \"${KLEE_UCLIBC_C_BCA}\"")
   endif()