about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Liew <daniel.liew@imperial.ac.uk>2016-12-09 18:40:00 +0000
committerDan Liew <daniel.liew@imperial.ac.uk>2016-12-09 18:45:20 +0000
commit8b0ac06e13ee67b983bbb2491102971cc52d5391 (patch)
tree93c9190aa485d53ab6cc73e575e81c6b3fcb7b80 /CMakeLists.txt
parentd7b03c98210d056bdc9cbf75156c6758b0dfa712 (diff)
downloadklee-8b0ac06e13ee67b983bbb2491102971cc52d5391.tar.gz
[CMake] Fix bug where if KLEE was built with `ENABLE_TCMALLOC`
and then re-configured with `ENABLE_TCMALLOC` set to OFF then
`klee/Config/config.h` was not correctly re-generated.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68e83733..2dc2cc2f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -432,6 +432,8 @@ if (ENABLE_TCMALLOC)
     message(FATAL_ERROR "Can't find \"${TCMALLOC_HEADER}\"")
   endif()
 else()
+  unset(HAVE_GPERFTOOLS_MALLOC_EXTENSION_H)
+  unset(HAVE_GPERFTOOLS_MALLOC_EXTENSION_H CACHE)
   message(STATUS "TCMalloc support disabled")
 endif()