about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Liew <daniel.liew@imperial.ac.uk>2016-12-17 13:44:03 +0000
committerDan Liew <daniel.liew@imperial.ac.uk>2017-01-16 22:45:05 +0000
commitd7e82a2d4e0f588faebfb6e44d01e685587f6872 (patch)
treeb432df2982b1f97a6d4ca70ea1ae8d66f8826910 /CMakeLists.txt
parentaedbca881945da47005835a405188041b40ae7cc (diff)
downloadklee-d7e82a2d4e0f588faebfb6e44d01e685587f6872.tar.gz
[CMake] Rename "integrationtests" to "systemtests".
This was a proposal from #500.

@andreamattavelli pointed out that the lit tests are really
system tests rather than integration tests so this commit fixes
the inappropriate naming that I chose.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e860f3e2..7d392f18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -699,24 +699,24 @@ if ((NOT LIT_TOOL) OR (NOT EXISTS "${LIT_TOOL}"))
     message(STATUS "Using lit: ${LIT_TOOL}")
   endif()
 
-  option(ENABLE_UNIT_TESTS "Enable unittests" ON)
+  option(ENABLE_UNIT_TESTS "Enable unit tests" ON)
   if (ENABLE_UNIT_TESTS)
     message(STATUS "Unit tests enabled")
     add_subdirectory(unittests)
   else()
     message(STATUS "Unit tests disabled")
   endif()
-  option(ENABLE_INTEGRATION_TESTS "Enable integration tests" ON)
-  if (ENABLE_INTEGRATION_TESTS)
-    message(STATUS "Integration tests enabled")
+  option(ENABLE_SYSTEM_TESTS "Enable system tests" ON)
+  if (ENABLE_SYSTEM_TESTS)
+    message(STATUS "System tests enabled")
     add_subdirectory(test)
   else()
-    message(STATUS "Integration tests disabled")
+    message(STATUS "System tests disabled")
   endif()
 
   # Add global test target
   add_custom_target(check
-    DEPENDS unittests integrationtests
+    DEPENDS unittests systemtests
     COMMENT "Running tests"
   )
 else()