about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Nowack <m.nowack@imperial.ac.uk>2018-06-12 13:29:31 +0100
committerCristian Cadar <c.cadar@imperial.ac.uk>2018-07-04 22:14:58 +0100
commitbfb5db0ff25740a619071d45d3b7186d0d4c08b5 (patch)
treef902edadf72d8bcbda8142bc63205761d239cba0 /CMakeLists.txt
parent4b3f93f3910e22629a24bc0dbd6947b1269fd5f4 (diff)
downloadklee-bfb5db0ff25740a619071d45d3b7186d0d4c08b5.tar.gz
Link dynamic libraries with specific paths instead of resolving them during runtime
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6019e428..efe7fdd9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -144,6 +144,9 @@ else()
 endif()
 
 
+# Reference specific library paths used during linking for install
+SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+
 ################################################################################
 # Add our CMake module directory to the list of module search directories
 ################################################################################
@@ -161,6 +164,7 @@ set(KLEE_COMPONENT_CXX_FLAGS "")
 set(KLEE_SOLVER_LIBRARIES "")
 set(KLEE_COMPONENT_EXTRA_LIBRARIES "")
 
+
 ################################################################################
 # Assertions
 ################################################################################
@@ -640,6 +644,7 @@ message(STATUS "KLEE_COMPONENT_EXTRA_INCLUDE_DIRS: '${KLEE_COMPONENT_EXTRA_INCLU
 message(STATUS "KLEE_COMPONENT_CXX_DEFINES: '${KLEE_COMPONENT_CXX_DEFINES}'")
 message(STATUS "KLEE_COMPONENT_CXX_FLAGS: '${KLEE_COMPONENT_CXX_FLAGS}'")
 message(STATUS "KLEE_COMPONENT_EXTRA_LIBRARIES: '${KLEE_COMPONENT_EXTRA_LIBRARIES}'")
+message(STATUS "KLEE_SOLVER_LIBRARIES: '${KLEE_SOLVER_LIBRARIES}'")
 
 ################################################################################
 # KLEE components