about summary refs log tree commit diff homepage
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2010-08-05 17:53:03 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2010-08-05 17:53:03 +0000
commitae6b58bba9c18954c6156223eb3df810fcf0dbbd (patch)
tree8be3f8dbc8e10d6deebb64438e037dca49d9e44c /autoconf/configure.ac
parent4440b96b3d92802ee327609e713f351065d25063 (diff)
downloadklee-ae6b58bba9c18954c6156223eb3df810fcf0dbbd.tar.gz
Add support for Debug+Asserts configuration
git-svn-id: https://llvm.org/svn/llvm-project/klee/trunk@110349 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 015c4f44..3be97790 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -231,6 +231,9 @@ if test X${with_runtime} = XRelease; then
 elif test X${with_runtime} = XDebug; then
    AC_MSG_RESULT([Debug])
    AC_SUBST(RUNTIME_ENABLE_OPTIMIZED,[[0]])
+elif test X${with_runtime} = XDebug+Asserts; then
+   AC_MSG_RESULT([Debug+Asserts])
+   AC_SUBST(RUNTIME_ENABLE_OPTIMIZED,[[0]])
 else
    AC_MSG_ERROR([invalid configuration: ${with_runtime}])
 fi