about summary refs log tree commit diff homepage
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJulian Büning <julian.buening@rwth-aachen.de>2019-08-04 21:17:28 +0200
committerCristian Cadar <c.cadar@imperial.ac.uk>2019-09-05 09:39:19 +0100
commit11dd657333ec8e90945fe793c0ad40eadb0e0646 (patch)
treec7e6462f4539deea898d82919e96cf4b6d203382 /test/CMakeLists.txt
parenta8abaa43873b8ee49320035817fcdd70a9879bda (diff)
downloadklee-11dd657333ec8e90945fe793c0ad40eadb0e0646.tar.gz
test/CMakeLists.txt: use official llvm monorepo for download
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 30ccf6b2..06bf5d28 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -62,7 +62,11 @@ if (NOT EXISTS "${LLVM_TOOLS_BINARY_DIR}/not")
 endif()
 
 if (DOWNLOAD_FILECHECK_SOURCE)
-  set(FILECHECK_SRC_URL "https://raw.githubusercontent.com/llvm-mirror/llvm/release_${LLVM_VERSION_MAJOR}${LLVM_VERSION_MINOR}/utils/FileCheck/FileCheck.cpp")
+  if (${LLVM_VERSION_MAJOR} GREATER 3)
+    set(FILECHECK_SRC_URL "https://raw.githubusercontent.com/llvm/llvm-project/release/${LLVM_VERSION_MAJOR}.x/llvm/utils/FileCheck/FileCheck.cpp")
+  else()
+    set(FILECHECK_SRC_URL "https://raw.githubusercontent.com/llvm/llvm-project/release/${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}.x/llvm/utils/FileCheck/FileCheck.cpp")
+  endif()
   set(FILECHECK_SRC_FILE "${CMAKE_CURRENT_BINARY_DIR}/FileCheck.cpp")
   if (NOT EXISTS "${FILECHECK_SRC_FILE}")
     message(STATUS "Downloading LLVM FileCheck source")
@@ -79,7 +83,11 @@ if (DOWNLOAD_FILECHECK_SOURCE)
 endif()
 
 if (DOWNLOAD_NOT_SOURCE)
-  set(NOT_SRC_URL "https://raw.githubusercontent.com/llvm-mirror/llvm/release_${LLVM_VERSION_MAJOR}${LLVM_VERSION_MINOR}/utils/not/not.cpp")
+  if (${LLVM_VERSION_MAJOR} GREATER 3)
+    set(NOT_SRC_URL "https://raw.githubusercontent.com/llvm/llvm-project/release/${LLVM_VERSION_MAJOR}.x/llvm/utils/not/not.cpp")
+  else()
+    set(NOT_SRC_URL "https://raw.githubusercontent.com/llvm/llvm-project/release/${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}.x/llvm/utils/not/not.cpp")
+  endif()
   set(NOT_SRC_FILE "${CMAKE_CURRENT_BINARY_DIR}/not.cpp")
   if (NOT EXISTS "${NOT_SRC_FILE}")
     message(STATUS "Downloading LLVM not source")