about summary refs log tree commit diff homepage
path: root/tools/gen-bout/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Santosa <santosa_1999@yahoo.com>2018-06-21 14:14:08 +0800
committerCristian Cadar <c.cadar@imperial.ac.uk>2018-10-26 18:33:00 +0300
commitbe340780e6261416320dd099753e17080de69534 (patch)
tree5b0c252c821117e70d0520211a0eaf53cf4eddce /tools/gen-bout/CMakeLists.txt
parent0525bd791318fe0ce2b68a7b4596f34c2770ef53 (diff)
downloadklee-be340780e6261416320dd099753e17080de69534.tar.gz
Added gen-bout tool to generate ktest file (file.bout) using specified concrete arguments and files.
* Sample use cases:
  * Using an interesting input as a seed, such as a crashing input.
  * Analyzing the path condition of a crashing input.
* Also added the test: test/Runtime/POSIX/GenBout.c
Diffstat (limited to 'tools/gen-bout/CMakeLists.txt')
-rw-r--r--tools/gen-bout/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tools/gen-bout/CMakeLists.txt b/tools/gen-bout/CMakeLists.txt
new file mode 100644
index 00000000..07cfb3c7
--- /dev/null
+++ b/tools/gen-bout/CMakeLists.txt
@@ -0,0 +1,17 @@
+#===------------------------------------------------------------------------===#
+#
+#                     The KLEE Symbolic Virtual Machine
+#
+# This file is distributed under the University of Illinois Open Source
+# License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+add_executable(gen-bout
+  gen-bout.cpp
+)
+
+set(KLEE_LIBS kleeBasic)
+
+target_link_libraries(gen-bout ${KLEE_LIBS})
+
+install(TARGETS gen-bout RUNTIME DESTINATION bin)