about summary refs log tree commit diff homepage
path: root/tools/klee-zesti/CMakeLists.txt
diff options
context:
space:
mode:
authorTimotej Kapus <tk1713@ic.ac.uk>2020-02-21 16:55:11 +0000
committerCristian Cadar <c.cadar@imperial.ac.uk>2020-09-17 18:17:25 +0100
commit52dfb5246697dc68f007e058f817b23310cae708 (patch)
tree8bd9ff6f2935e0b0530474102bafc089b490de59 /tools/klee-zesti/CMakeLists.txt
parent7bd9582967636f9f4f9acecadd26ab8faef74323 (diff)
downloadklee-52dfb5246697dc68f007e058f817b23310cae708.tar.gz
Add klee-zesti a ZESTI like wrapper script
klee-zesti takes concrete arguments, files and stdin of the program under tests
converts them to a seed and then runs klee with that seed. This emulates the interface of ZESTI.
Diffstat (limited to 'tools/klee-zesti/CMakeLists.txt')
-rw-r--r--tools/klee-zesti/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/klee-zesti/CMakeLists.txt b/tools/klee-zesti/CMakeLists.txt
new file mode 100644
index 00000000..20ad1ad0
--- /dev/null
+++ b/tools/klee-zesti/CMakeLists.txt
@@ -0,0 +1,13 @@
+#===------------------------------------------------------------------------===#
+#
+#                     The KLEE Symbolic Virtual Machine
+#
+# This file is distributed under the University of Illinois Open Source
+# License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+install(PROGRAMS klee-zesti DESTINATION bin)
+
+# Copy into the build directory's binary directory
+# so system tests can find it
+configure_file(klee-zesti "${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/klee-zesti" COPYONLY)