about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0f5fd26..6fc3878a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -395,9 +395,8 @@ endif()
 ###############################################################################
 if (NOT LLVM_ENABLE_RTTI)
   if (ENABLE_SOLVER_METASMT AND metaSMT_REQUIRE_RTTI)
-    message(WARNING "Not disabling RTTI because metaSMT uses them")
-    # FIXME: Should this be FATAL_ERROR rather than ERROR?
-    message(WARNING
+    message(FATAL_ERROR
+      "RTTI cannot be disabled because metaSMT uses them."
       "This build configuration is not supported and will likely not work."
       "You should recompile LLVM with RTTI enabled.")
   else()