about summary refs log tree commit diff homepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2dc2cc2f..e860f3e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -194,6 +194,7 @@ set(NEEDED_LLVM_VARS
   LLVM_INCLUDE_DIRS
   LLVM_LIBRARY_DIRS
   LLVM_TOOLS_BINARY_DIR
+  LLVM_ENABLE_VISIBILITY_INLINES_HIDDEN
   TARGET_TRIPLE
 )
 
@@ -211,6 +212,10 @@ else()
   unset(ENABLE_KLEE_DEBUG) # for config.h
 endif()
 
+if (LLVM_ENABLE_VISIBILITY_INLINES_HIDDEN)
+  list(APPEND KLEE_COMPONENT_CXX_FLAGS "-fvisibility-inlines-hidden")
+endif()
+
 
 list(APPEND KLEE_COMPONENT_CXX_DEFINES ${LLVM_DEFINITIONS})
 list(APPEND KLEE_COMPONENT_EXTRA_INCLUDE_DIRS ${LLVM_INCLUDE_DIRS})