about summary refs log tree commit diff homepage
path: root/autoconf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'autoconf/configure.ac')
-rw-r--r--autoconf/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/autoconf/configure.ac b/autoconf/configure.ac
index 8d4f465c..747f6544 100644
--- a/autoconf/configure.ac
+++ b/autoconf/configure.ac
@@ -34,8 +34,11 @@ AH_BOTTOM([#endif])
 
 dnl We need to check for the compiler up here to avoid anything else
 dnl starting with a different one.
+AC_PROG_CC(gcc clang)
 AC_PROG_CXX(g++ clang++ )
 AC_LANG([C++])
+AC_SUBST(KLEE_HOST_C_COMPILER,$CC)
+AC_SUBST(KLEE_HOST_CXX_COMPILER,$CXX)
 
 dnl **************************************************************************
 dnl Find the host