about summary refs log tree commit diff homepage
path: root/lib/Expr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Expr/CMakeLists.txt')
-rw-r--r--lib/Expr/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/lib/Expr/CMakeLists.txt b/lib/Expr/CMakeLists.txt
new file mode 100644
index 00000000..6ea77544
--- /dev/null
+++ b/lib/Expr/CMakeLists.txt
@@ -0,0 +1,23 @@
+#===------------------------------------------------------------------------===#
+#
+#                     The KLEE Symbolic Virtual Machine
+#
+# This file is distributed under the University of Illinois Open Source
+# License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+klee_add_component(kleaverExpr
+	ArrayCache.cpp
+	Assigment.cpp
+	Constraints.cpp
+	ExprBuilder.cpp
+	Expr.cpp
+	ExprEvaluator.cpp
+	ExprPPrinter.cpp
+	ExprSMTLIBPrinter.cpp
+	ExprUtil.cpp
+	ExprVisitor.cpp
+	Lexer.cpp
+	Parser.cpp
+	Updates.cpp
+)