about summary refs log tree commit diff homepage
path: root/lib/Module/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Module/CMakeLists.txt')
-rw-r--r--lib/Module/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/lib/Module/CMakeLists.txt b/lib/Module/CMakeLists.txt
index c1a5d809..a549d60a 100644
--- a/lib/Module/CMakeLists.txt
+++ b/lib/Module/CMakeLists.txt
@@ -38,9 +38,4 @@ klee_get_llvm_libs(LLVM_LIBS ${LLVM_COMPONENTS})
 target_link_libraries(kleeModule PUBLIC ${LLVM_LIBS})
 target_link_libraries(kleeModule PRIVATE
   kleeSupport
-  # FIXME:
-  # There is a circular dependency between `kleeModule` and `kleeCore`.
-  # `ModuleUtil.cpp` uses `klee::SpecialFunctionHandler` (in `kleeCore`) but
-  # `kleeCore` uses `kleeModule`.
-  kleeCore
 )