about summary refs log tree commit diff homepage
path: root/lib/Support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Support/CMakeLists.txt')
-rw-r--r--lib/Support/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/lib/Support/CMakeLists.txt b/lib/Support/CMakeLists.txt
new file mode 100644
index 00000000..4bf7ea7d
--- /dev/null
+++ b/lib/Support/CMakeLists.txt
@@ -0,0 +1,20 @@
+#===------------------------------------------------------------------------===#
+#
+#                     The KLEE Symbolic Virtual Machine
+#
+# This file is distributed under the University of Illinois Open Source
+# License. See LICENSE.TXT for details.
+#
+#===------------------------------------------------------------------------===#
+klee_add_component(kleeSupport
+	CompressionStream.cpp
+	ErrorHandling.cpp
+	MemoryUsage.cpp
+	PrintVersion.cpp
+	RNG.cpp
+	Time.cpp
+	Timer.cpp
+	TreeStream.cpp
+)
+
+target_link_libraries(kleeSupport PRIVATE ${ZLIB_LIBRARIES})