about summary refs log tree commit diff homepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 570f39bd..8e14a489 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,10 +1,10 @@
 with import <nixpkgs> {};
 let symbdiff = callPackage ./tools/symbdiff { };
 in mkShell {
-  packages = [ clang symbdiff ];
+  packages = [ llvmPackages_12.clang symbdiff ];
   shellHook = ''
     # clang -emit-llvm -c -DKLEE_RUNTIME metaprogram.c for bitcode
     # clang -o metaprogram{,.c} for binary
-    alias clang='clang -g -O0 -Xclang -disable-O0-optnone'
+    alias clang='clang -g -O0 -Xclang -disable-O0-optnone -fsanitize=undefined -fno-sanitize=local-bounds,function,vptr'
  '';
 }