about summary refs log tree commit diff homepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..9d361a5f
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,8 @@
+with import <nixpkgs> {};
+let symbdiff = callPackage ./tools/symbdiff { };
+in mkShell {
+  packages = [ clang symbdiff ];
+  shellHook = ''
+    alias klang='clang -emit-llvm -c -g -O0 -Xclang -disable-O0-optnone'
+ '';
+}