summary refs log tree commit diff
diff options
context:
space:
mode:
authorArtyom Bologov <aartaka@protonmail.com>2023-06-16 19:52:53 +0400
committerGuillaume Le Vaillant <glv@posteo.net>2023-06-17 11:25:23 +0200
commit010e79f2926f80b5a27f6a47628764296b8bb059 (patch)
treeb38d93d479bebfe925a243e421b7935d8ede72a4
parent23f77bd7b87ac6cc844b6fb6a0f0e383677d562e (diff)
downloadguix-010e79f2926f80b5a27f6a47628764296b8bb059.tar.gz
gnu: cl-colors2: Update to 0.5.4-3.cc03bad.
* gnu/packages/lisp-xyz.scm (sbcl-cl-colors2): Update to 0.5.4-3.cc03bad.
  [description]: Update with the latest changes.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 61f0414fac..d578c46b90 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11717,20 +11717,20 @@ be used with @code{cl-yacc}.")
   (sbcl-package->ecl-package sbcl-cl-lex))
 
 (define-public sbcl-cl-colors2
-  (let ((commit "d620e7fb504bbec3ed48cc7cd03f60ce2bb3735d")
-        (revision "2"))
+  (let ((commit "cc03badf5f69be65ae7e13c2f9a7c16838ab8241")
+        (revision "3"))
     (package
       (name "sbcl-cl-colors2")
-      (version (git-version "0.5.0" revision commit))
+      (version (git-version "0.5.4" revision commit))
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://notabug.org/cage/cl-colors2.git")
                (commit commit)))
-         (file-name (git-file-name name version))
+         (file-name (git-file-name "cl-colors2" version))
          (sha256
-          (base32 "14wx006lv4bhf86z68484kphm5jsh86ns60pb4i1bi8kl8lp03r0"))))
+          (base32 "1l7sl7nnvq13xmss9wwkhcq123bsylskxjrijwfkqp6sm02gbd15"))))
       (build-system asdf-build-system/sbcl)
       (native-inputs
        (list sbcl-clunit2))
@@ -11741,11 +11741,10 @@ be used with @code{cl-yacc}.")
        "This is a very simple color library for Common Lisp, providing:
 
 @itemize
-@item Types for representing colors in HSV and RGB spaces.
-@item Simple conversion functions between the above types (and also
-hexadecimal representation for RGB).
-@item Some predefined colors (currently X11 color names -- of course
-the library does not depend on X11).
+@item Types for representing colors in HSV, HSL, and RGB spaces.
+@item Simple conversion functions between the above types.
+@item Function printing colors to HEX, RGB, RGBA, and HSL.
+@item Predefined colors from X11, SVG, and GDK.
 @end itemize\n")
       (home-page "https://notabug.org/cage/cl-colors2")
       (license license:boost1.0))))