summary refs log tree commit diff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-23 10:51:44 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-14 23:53:34 -0400
commit0293a06e5524ca9e894f111f68c1c9e7b6263810 (patch)
treefe71f990d2587420194302cfb4ae391d6aaafcb2
parentd2fce9c85e92cd7b1ebcd69ef130fb31f9d51bc9 (diff)
downloadguix-0293a06e5524ca9e894f111f68c1c9e7b6263810.tar.gz
gnu: gnome-clocks: Update to 3.34.0.
* gnu/packages/gnome.scm (gnome-clocks): Update to 3.34.0.
[arguments]: Add phase to skip gtk-update-icon-cache.
[native-inputs]: Remove gtk+:bin.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8afa33182e..0892464b1b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7965,7 +7965,7 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
 (define-public gnome-clocks
   (package
     (name "gnome-clocks")
-    (version "3.32.0")
+    (version "3.34.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -7973,15 +7973,22 @@ Microsoft SkyDrive and Hotmail, using their REST protocols.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1w6lgjdak3x76c9gyhd1lqrdmjfh8q77sjnrkcimylsg0jq913bc"))))
+                "0g7hjk55smhkd09hwa9kag3h5a12l494wj89w9smpdk3ghsmy6b1"))))
     (build-system meson-build-system)
     (arguments
-     '(#:glib-or-gtk? #t))
+     '(#:glib-or-gtk? #t
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-gtk-update-icon-cache
+           ;; Don't create 'icon-theme.cache'.
+           (lambda _
+             (substitute* "build-aux/post-install.py"
+               (("gtk-update-icon-cache") "true"))
+             #t)))))
     (native-inputs
      `(("vala" ,vala)
        ("pkg-config" ,pkg-config)
        ("glib" ,glib "bin")             ; for glib-compile-resources
-       ("gtk+-bin" ,gtk+ "bin")         ; for gtk-update-icon-cache
        ("desktop-file-utils" ,desktop-file-utils)
        ("gettext" ,gettext-minimal)
        ("itstool" ,itstool)))