summary refs log tree commit diff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-07-03 15:08:11 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 17:45:48 +0200
commit07f083e94f4f5c5f53e4d8aa644de2064a6256c9 (patch)
tree63f7b088de44a26c9bb7f35458816c53119c09d4
parentf821c06b676074c37451501e661515020a0a8b9a (diff)
downloadguix-07f083e94f4f5c5f53e4d8aa644de2064a6256c9.tar.gz
gnu: Add python-gatspy.
* gnu/packages/bioinformatics.scm (python-gatspy): New variable.
-rw-r--r--gnu/packages/astronomy.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1dca667ef0..3a1b584808 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -562,6 +562,39 @@ CFITSIO library.  Among other things, it can
 @end itemize")
     (license license:gpl2+)))
 
+(define-public python-gatspy
+  (package
+    (name "python-gatspy")
+    (version "0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "gatspy" version))
+              (sha256
+               (base32
+                "1gw2z6x8nikvnw2gkdl70gr81cwczd1pd7v8ry2kjn6k4kssrfav"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      '(modify-phases %standard-phases
+         ;; Tests need this
+         (add-before 'check 'set-HOME
+           (lambda _ (setenv "HOME" "/tmp"))))
+      #:test-flags
+      '(list "-k"
+             (string-append
+              ;; These tests require internet access
+              "not test_download_data.py"
+              ;; XXX: we don't have supersmoother
+              " and not test_supersmoother.py"))))
+    (propagated-inputs (list python-astroml python-numpy python-scipy))
+    (native-inputs (list python-pytest python-nose python-setuptools-scm))
+    (home-page "https://github.com/astroml/gatspy")
+    (synopsis "General tools for astronomical time series in Python")
+    (description "This package provides general tools for astronomical time
+series in Python.")
+    (license license:bsd-2)))
+
 (define-public qfits
   (package
     (name "qfits")