summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:08 +0200
commit07f436ce1301c9dc6344b3af03f8a159e35edbbd (patch)
tree4d571d715e3984a7d59ff2c12da00bff742081b2
parent2ca16e4318bcf5986610490d75f2a333ede31bec (diff)
downloadguix-07f436ce1301c9dc6344b3af03f8a159e35edbbd.tar.gz
gnu: libnvme: Separate :doc files.
Also fix the .rst files being dumped in the root of the output.

* gnu/packages/linux.scm (libnvme)[outputs]: Add "doc".
[arguments]: Install HTML and RST documentation there.
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cf67a63331..bfccd1afb7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5142,11 +5142,14 @@ Translation (@dfn{SAT}) are also supported.")
                (base32 "1wq8bw60l090z2kb717wyzk5wz1jrcn31ykdaa7k9pz9w79v0v67"))
               (file-name (git-file-name name version))))
     (build-system meson-build-system)
+    (outputs (list "out" "doc"))        ; docs are 80% of all output
     (arguments
      (list
-      #:configure-flags #~(list (format #f "-Dhtmldir=~a/share/doc/~a/html"
-                                        #$output #$name)
-                                "-Ddocs-build=true" "-Ddocs=all")))
+      #:configure-flags
+      #~(let ((doc (string-append #$output:doc "/share/doc/" #$name)))
+          (list (string-append "-Dhtmldir=" doc "/html")
+                (string-append "-Drstdir=" doc "/rst")
+                "-Ddocs-build=true" "-Ddocs=all"))))
     (native-inputs (list pkg-config perl python python-sphinx))
     ;; libnvme.pc, libnvme-mi.pc lists these in Requires.private.
     (propagated-inputs (list dbus json-c openssl))