summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-07-18 23:19:30 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-11-16 19:02:24 -0500
commit19b396bf31ad633142ea8ca8058ce23c37a627d7 (patch)
tree8e682e6d58857f1d5d86e34937152fc85a9675e4
parent7b3f6a277cbd544754b1bdee3aa737f6a0f457a3 (diff)
downloadguix-19b396bf31ad633142ea8ca8058ce23c37a627d7.tar.gz
gnu: Add openal.
* gnu/packages/games.scm (openal): New variable.
-rw-r--r--gnu/packages/games.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a05d389e82..2b6475bd5c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -52,7 +52,10 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages pulseaudio)
+  #:use-module (gnu packages linux)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system trivial))
 
 (define-public gnubg
@@ -535,3 +538,32 @@ clone.")
     ;; As noted in 'COPYING', part of it is under GPLv2+, while the rest is
     ;; under BSD-2.
     (license gpl2+)))
+
+(define-public openal
+  (package
+    (name "openal")
+    (version "1.15.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://kcat.strangesoft.net/openal-releases/openal-soft-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "0mmhdqiyb3c9dzvxspm8h2v8jibhi8pfjxnf6m0wn744y1ia2a8f"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ; no check target
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("pulseaudio" ,pulseaudio)))
+    (synopsis "3D audio API")
+    (description
+     "OpenAL provides capabilities for playing audio in a virtual 3D
+environment.  Distance attenuation, doppler shift, and directional sound
+emitters are among the features handled by the API.  More advanced effects,
+including air absorption, occlusion, and environmental reverb, are available
+through the EFX extension.  It also facilitates streaming audio, multi-channel
+buffers, and audio capture.")
+    (home-page "http://kcat.strangesoft.net/openal.html")
+    (license lgpl2.0+)))