summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-04-20 16:27:44 +0300
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:26 -0400
commit1c7a95741e7d96903e84f544b1774ee5cb741dfa (patch)
tree560b7032a55817d6ce3cf80424a826bef68a9bc0
parent2fc668c519c157ce8fe21cbec90c70ddc1daf096 (diff)
downloadguix-1c7a95741e7d96903e84f544b1774ee5cb741dfa.tar.gz
gnu: glib: Disable failing test.
* gnu/packages/glib.scm (glib)[source]: Add patch.
[arguments]: Remove custom 'increase-test-timeout phase.
* gnu/packages/patches/glib-skip-failing-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/glib.scm14
-rw-r--r--gnu/packages/patches/glib-skip-failing-test.patch27
3 files changed, 30 insertions, 12 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 71e9719f54..5ea7e6107d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1113,6 +1113,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/ghostscript-no-header-creationdate.patch \
   %D%/packages/patches/giara-fix-login.patch                      \
   %D%/packages/patches/glib-appinfo-watch.patch			\
+  %D%/packages/patches/glib-skip-failing-test.patch		\
   %D%/packages/patches/glibc-CVE-2018-11236.patch		\
   %D%/packages/patches/glibc-CVE-2018-11237.patch		\
   %D%/packages/patches/glibc-CVE-2019-7309.patch		\
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 4659d138f6..5fb266c555 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -186,7 +186,8 @@ shared NFS home directories.")
        (sha256
         (base32 "1sh3h6b734cxhdd1qlzvhxq6rc7k73dsisap5y3s419s9xc4ywv7"))
        (patches
-        (search-patches "glib-appinfo-watch.patch"))
+        (search-patches "glib-appinfo-watch.patch"
+                        "glib-skip-failing-test.patch"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -202,17 +203,6 @@ shared NFS home directories.")
        #:configure-flags '("-Dman=true")
        #:phases
        (modify-phases %standard-phases
-         ;; TODO: Remove the conditional in the next core-updates cycle.
-         ;; Needed to build glib on slower ARM nodes.
-         ,@(if (string-prefix? "arm" (%current-system))
-               `((add-after 'unpack 'increase-test-timeout
-                   (lambda _
-                     (substitute* "meson.build"
-                       (("test_timeout = 60")
-                        "test_timeout = 90")
-                       (("test_timeout_slow = 120")
-                        "test_timeout_slow = 180")))))
-               '())
          (add-after 'unpack 'disable-failing-tests
            (lambda _
              (with-directory-excursion "glib/tests"
diff --git a/gnu/packages/patches/glib-skip-failing-test.patch b/gnu/packages/patches/glib-skip-failing-test.patch
new file mode 100644
index 0000000000..c7706aaa74
--- /dev/null
+++ b/gnu/packages/patches/glib-skip-failing-test.patch
@@ -0,0 +1,27 @@
+This test timed out on powerpc-linux even after extending the
+test_timeout_slow to 1800 seconds. Previously we tried to work around
+this test by extending test_timeout_slow by 1.5 its previous value.
+
+---
+ gio/tests/meson.build | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/gio/tests/meson.build b/gio/tests/meson.build
+index a926ae0..4fdbe7a 100644
+--- a/gio/tests/meson.build
++++ b/gio/tests/meson.build
+@@ -317,10 +317,6 @@ if host_machine.system() != 'windows'
+         'extra_sources' : [extra_sources, gdbus_test_codegen_generated, gdbus_test_codegen_generated_interface_info],
+         'c_args' : ['-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_32'],
+       },
+-      'gdbus-threading' : {
+-        'extra_sources' : extra_sources,
+-        'suite' : ['slow'],
+-      },
+       'gmenumodel' : {
+         'extra_sources' : extra_sources,
+         'suite' : ['slow'],
+
+-- 
+2.31.1
+