summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-01 00:06:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-03 23:30:11 -0400
commit3557d7d8bcc5427a5c716cdd65b703812d4d681d (patch)
tree813469d0025cffda10fc2ad79a3154ef5b8ff35a
parent839bb42f0cc80dbdbcd101fffadd47ead93409d2 (diff)
downloadguix-3557d7d8bcc5427a5c716cdd65b703812d4d681d.tar.gz
gnu: pjproject: Include sensible configure flags from pjproject-jami.
This is done so the regular pjproject has more in common with
pjproject-jami, which allows simplifying its definition.

* gnu/packages/telephony.scm (pjproject)[configure-flags]: Add
'--enable-epoll' when the system is Linux.  Define CFLAGS with
the '-DNDEBUG' options.
-rw-r--r--gnu/packages/telephony.scm32
1 files changed, 21 insertions, 11 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index cc31cd6a36..2c50b34eae 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -749,17 +749,27 @@ your calls and messages.")
     (arguments
      `(#:tests? #t
        #:test-target "selftest"
-      configure-flags '("--with-external-speex"
-                           "--with-external-gsm"
-                           "--with-external-srtp"
-                           "--with-external-pa"
-                           "--with-gnutls"         ;disable OpenSSL checks
-                           "--disable-libyuv"      ;TODO: add missing package
-                           "--disable-silk"        ;TODO: add missing package
-                           "--disable-libwebrtc"   ;TODO: add missing package
-                           "--disable-ilbc-codec"  ;cannot be unbundled
-                           "--disable-g7221-codec" ;TODO: add missing package
-                           "--enable-libsamplerate")
+       #:configure-flags
+       (list "--with-external-speex"
+             "--with-external-gsm"
+             "--with-external-srtp"
+             "--with-external-pa"
+             ;; The following flag is Linux specific.
+             ,@(if (string-contains (or (%current-system)
+                                        (%current-target-system)) "linux")
+                   '("--enable-epoll")
+                   '())
+             "--with-gnutls"            ;disable OpenSSL checks
+             "--disable-libyuv"         ;TODO: add missing package
+             "--disable-silk"           ;TODO: add missing package
+             "--disable-libwebrtc"      ;TODO: add missing package
+             "--disable-ilbc-codec"     ;cannot be unbundled
+             "--disable-g7221-codec"    ;TODO: add missing package
+             "--enable-libsamplerate"
+             ;; -DNDEBUG is set to prevent pjproject from raising
+             ;; assertions that aren't critical, crashing
+             ;; applications as the result.
+             "CFLAGS=-DNDEBUG")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'make-source-files-writable