summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-22 06:38:38 +0100
committerMarius Bakke <marius@gnu.org>2022-11-22 08:37:23 +0100
commit3d2de69c066518a95bb8bc07e306cd2c337ef12c (patch)
tree7495c78ac100cbedebac271380693dfde08a28ae
parentae24d4b34af54017d62ec30364219fa3482e9fd9 (diff)
downloadguix-3d2de69c066518a95bb8bc07e306cd2c337ef12c.tar.gz
gnu: gpgme: Add 1.18.0.
* gnu/packages/gnupg.scm (gpgme-1.18, qgpgme-1.18): New variables.
-rw-r--r--gnu/packages/gnupg.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 210b1ab8b3..064b775ab1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -431,6 +431,19 @@ and every application benefits from this.")
     (properties '((ftp-server . "ftp.gnupg.org")
                   (ftp-directory . "/gcrypt/gpgme")))))
 
+;; TODO: Merge with gpgme in the next rebuild cycle.
+(define-public gpgme-1.18
+  (package
+    (inherit gpgme)
+    (version "1.18.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnupg/gpgme/gpgme-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "17hfigfnq6xz45b5xrp299f68b5mwx0aysd51sx5v4nf8yp4w79n"))))))
+
 (define-public qgpgme
   (package
     (inherit gpgme)
@@ -459,6 +472,16 @@ QGpgME was originally developed as part of libkleo and incorporated into
 gpgpme starting with version 1.7.")
     (license license:gpl2+))) ;; Note: this differs from gpgme
 
+;; TODO: Merge with qgpgme in the next rebuild cycle.
+(define-public qgpgme-1.18
+  (package
+    (inherit qgpgme)
+    (version (package-version gpgme-1.18))
+    (source (package-source gpgme-1.18))
+    (inputs
+     (modify-inputs (package-inputs qgpgme)
+       (replace "gpgme" gpgme-1.18)))))
+
 (define-public guile-gcrypt
   (package
     (name "guile-gcrypt")