summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 18:22:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-03 20:09:29 +0100
commit417b07ab34e72d613d877fb0fde25c3cbc6805a5 (patch)
tree28aa13a98e07dbe00b7d8453b515fa3a0d9f7da4
parent2acbc174b0d4b1d18fd8ffcfbfed24464b6479c1 (diff)
downloadguix-417b07ab34e72d613d877fb0fde25c3cbc6805a5.tar.gz
gnu: yaml-cpp: Don't use unstable tarball.
* gnu/packages/serialization.scm (yaml-cpp)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/serialization.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 48dcf8d0ab..2bd1872bfd 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -261,14 +261,15 @@ that implements both the msgpack and msgpack-rpc specifications.")
   (package
     (name "yaml-cpp")
     (version "0.6.3")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/jbeder/yaml-cpp/archive/"
-                    "yaml-cpp-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1vgi193c761xaalq7r62ahiyvg7m32ab4z104k1s12kinf81pskp"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/jbeder/yaml-cpp.git")
+             (commit (string-append "yaml-cpp-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ykkxzxcwwiv8l8r697gyqh1nl582krpvi7m7l6b40ijnk4pw30s"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags '("-DYAML_BUILD_SHARED_LIBS=ON")))