summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-04 17:11:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-04 17:11:52 +0200
commit48542e03cfa6eb41de22f723f73bbfbde8329978 (patch)
tree3539877820c16c040cc3d9197a6510e688bc458c
parent1c3d7000a75014e80cd292a507035da860160005 (diff)
downloadguix-48542e03cfa6eb41de22f723f73bbfbde8329978.tar.gz
gnu: Add python-azure-storage-nspkg.
* gnu/packages/python-web.scm (python-azure-storage-nspkg): New variable.
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 3dcacef6b4..5df134ddff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6172,3 +6172,24 @@ your code non-blocking and speedy.")
     (description
      "This package is an internal Azure namespace package.")
     (license license:expat)))
+
+(define-public python-azure-storage-nspkg
+  (package
+    (name "python-azure-storage-nspkg")
+    (version "3.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "azure-storage-nspkg" version))
+       (sha256
+        (base32
+         "049qcmgshz7dj9yaqma0fwcgbxwddgwyfcw4gmv45xfmaa3bwfvg"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-azure-nspkg" ,python-azure-nspkg)))
+    (home-page "https://github.com/Azure/azure-storage-python")
+    (synopsis "Microsoft Azure Storage Namespace package")
+    (description
+     "This project provides a client library in Python that makes it easy to
+communicate with Microsoft Azure Storage services.")
+    (license license:expat)))