summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-06 14:54:40 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-06 14:54:40 +0100
commit50fe945c01e6829d34258ffefc4a5a9d68a908bd (patch)
tree0712bfdb3544bb03ce52fc9f7639375cad582cf9
parent12bcf94a9a3d2ea1817e15b517c78771d6260bbf (diff)
downloadguix-50fe945c01e6829d34258ffefc4a5a9d68a908bd.tar.gz
gnu: ots: Make sure the shared library has the '.so' extension.
Fixes <http://bugs.gnu.org/18521>.

* gnu/packages/ots.scm (ots)[arguments]: Add #:phases.
-rw-r--r--gnu/packages/ots.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/ots.scm b/gnu/packages/ots.scm
index e317245355..1c0d4a71f4 100644
--- a/gnu/packages/ots.scm
+++ b/gnu/packages/ots.scm
@@ -47,7 +47,19 @@
     (arguments
      ;; With '-jN', the rule to build the 'ots' command can be triggered
      ;; before libots-1.la has been built.
-     '(#:parallel-build? #f))
+     '(#:parallel-build? #f
+
+       #:phases (alist-cons-after
+                 'configure 'set-shared-lib-extension
+                 (lambda _
+                   ;; For some reason, the 'libtool' script (from Libtool
+                   ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
+                   ;; 'shrext' for the shared library file name extension.
+                   ;; This leads to the creation of 'libots-1' instead of
+                   ;; 'libots-1.so'.  Fix that.
+                   (substitute* "libtool"
+                     (("shrext_cmds") "shrext")))
+                 %standard-phases)))
     (inputs
       `(("glib" ,glib)
         ("popt" ,popt)