summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-30 16:18:34 +0200
committerMarius Bakke <marius@gnu.org>2021-07-30 16:18:41 +0200
commit730f11ba929eecfb4fd0322b82997c47fa4a7add (patch)
tree5a54aee2ba84868682a2f81d09f80ccdcbcf90c6
parent311cc4ee65c8b52b700628ff7204f6673a7194c9 (diff)
downloadguix-730f11ba929eecfb4fd0322b82997c47fa4a7add.tar.gz
gnu: python-elasticsearch: Update to 7.13.4.
* gnu/packages/python-web.scm (python-elasticsearch): Update to 7.13.4.
[native-inputs]: Remove.
[propagated-inputs]: Add PYTHON-CERTIFI.
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b75cb5ddfd..b4798ca8c2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3828,22 +3828,18 @@ CSS tidy.  Also supports URL rewriting in CSS files.")
 (define-public python-elasticsearch
   (package
     (name "python-elasticsearch")
-    (version "7.1.0")
+    (version "7.13.4")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "elasticsearch" version))
         (sha256
          (base32
-          "0rnjvlhw4v3vg14l519qliy1s1zpmx3827q0xfviwvk42rr7hh01"))))
+          "1q38w9nh2j2yi82d8rhzb57597l4lq5zx7xzfg45xf7ffrgsipaj"))))
     (build-system python-build-system)
-    (native-inputs
-     `(("python-mock" ,python-mock)
-       ("python-nosexcover" ,python-nosexcover)
-       ("python-pyaml" ,python-pyaml)
-       ("python-requests" ,python-requests)))
     (propagated-inputs
-     `(("urllib3" ,python-urllib3)))
+     `(("python-certifi" ,python-certifi)
+       ("python-urllib3" ,python-urllib3)))
     (arguments
      ;; tests require the test_elasticsearch module but it is not distributed.
      `(#:tests? #f))