summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-03-28 10:31:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-03-28 10:31:54 +0300
commit738da660ff51e03b5ef63af9fa81eb50cb222928 (patch)
tree67fcec73ddb3765b9fd5d0d88dbc76ae9e197e8a
parent58bc976b5b35ec58b228f8c2dbe35f2ff2ca9ad5 (diff)
downloadguix-738da660ff51e03b5ef63af9fa81eb50cb222928.tar.gz
gnu: zig: Remove unneeded patch.
* gnu/packages/zig.scm (zig)[source]: Remove one patch.
* gnu/packages/patches/zig-disable-libc-note-test.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/zig-disable-libc-note-test.patch31
-rw-r--r--gnu/packages/zig.scm5
3 files changed, 1 insertions, 36 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e2c2c326e3..4f60046a5e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1982,7 +1982,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/ytfzf-updates.patch        \
   %D%/packages/patches/ytnef-CVE-2021-3403.patch	\
   %D%/packages/patches/ytnef-CVE-2021-3404.patch	\
-  %D%/packages/patches/zig-disable-libc-note-test.patch         \
   %D%/packages/patches/zig-use-system-paths.patch
 
 MISC_DISTRO_FILES =				\
diff --git a/gnu/packages/patches/zig-disable-libc-note-test.patch b/gnu/packages/patches/zig-disable-libc-note-test.patch
deleted file mode 100644
index 4508cee200..0000000000
--- a/gnu/packages/patches/zig-disable-libc-note-test.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-This test fails with "error.CompilationIncorrectlySucceeded".
-
-diff --git a/test/compile_errors.zig b/test/compile_errors.zig
-index b1eaa0302..621f9db0a 100644
---- a/test/compile_errors.zig
-+++ b/test/compile_errors.zig
-@@ -2943,15 +2943,15 @@ pub fn addCases(ctx: *TestContext) !void {
-             "tmp.zig:3:5: error: dependency on libc must be explicitly specified in the build command",
-         });
- 
--        ctx.testErrStage1("libc headers note",
--            \\const c = @cImport(@cInclude("stdio.h"));
--            \\export fn entry() void {
--            \\    _ = c.printf("hello, world!\n");
--            \\}
--        , &[_][]const u8{
--            "tmp.zig:1:11: error: C import failed",
--            "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
--        });
-+        // ctx.testErrStage1("libc headers note",
-+        //     \\const c = @cImport(@cInclude("stdio.h"));
-+        //     \\export fn entry() void {
-+        //     \\    _ = c.printf("hello, world!\n");
-+        //     \\}
-+        // , &[_][]const u8{
-+        //     "tmp.zig:1:11: error: C import failed",
-+        //     "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
-+        // });
-     }
- 
-     ctx.testErrStage1("comptime vector overflow shows the index",
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
index 4c048ef580..fd907bc502 100644
--- a/gnu/packages/zig.scm
+++ b/gnu/packages/zig.scm
@@ -39,10 +39,7 @@
        (file-name (git-file-name name version))
        (sha256
         (base32 "0nfvgg23sw50ksy0z0ml6lkdsvmd0278mq29m23dbb2jsirkhry7"))
-       (patches
-        (search-patches
-         "zig-disable-libc-note-test.patch"
-         "zig-use-system-paths.patch"))))
+       (patches (search-patches "zig-use-system-paths.patch"))))
     (build-system cmake-build-system)
     (inputs
      (list clang-13 ; Clang propagates llvm.