summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-21 10:00:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-21 10:01:55 +0100
commit7c9cbc8d73cd7a385686db1ee8552e4760584a82 (patch)
treec78022fd8b3a8fec392568de4184b4963400eca9
parentf86475d012e528285c62a143e679dacb2a3240e4 (diff)
downloadguix-7c9cbc8d73cd7a385686db1ee8552e4760584a82.tar.gz
gnu: tractor: Use gexp.
* gnu/packages/tor.scm (tractor)[native-inputs]: Drop label.
[arguments]: Use gexp; drop trailing #T from build phases.
-rw-r--r--gnu/packages/tor.scm29
1 files changed, 13 insertions, 16 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index c21eab23dc..d88a840906 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017, 2018, 2019, 2021 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018, 2022 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2020 André Batista <nandre@riseup.net>
@@ -444,7 +444,7 @@ Potential client and exit connections are scrubbed of sensitive information.")
          "107iwkhw9rxbp4samlcw24gdvgqh23rd7z60lrl1b4iljmhqjvcs"))))
     (build-system python-build-system)
     (native-inputs
-     `(("glib:bin" ,glib "bin")))       ; for glib-compile-schemas.
+     (list (list glib "bin")))       ; for glib-compile-schemas.
     (inputs
      (list python-fire
            python-psutil
@@ -453,20 +453,17 @@ Potential client and exit connections are scrubbed of sensitive information.")
            python-stem
            python-termcolor))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'install-man-page
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (man1 (string-append out "/share/man/man1")))
-               (install-file "tractor/man/tractor.1" man1)
-               #t)))
-         (add-after 'install 'install-gschema
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (schemas (string-append out "/share/glib-2.0/schemas")))
-               (install-file "tractor/tractor.gschema.xml" schemas)
-               #t))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'install-man-page
+            (lambda _
+              (let ((man1 (string-append #$output "/share/man/man1")))
+                (install-file "tractor/man/tractor.1" man1))))
+          (add-after 'install 'install-gschema
+            (lambda _
+              (let ((schemas (string-append #$output "/share/glib-2.0/schemas")))
+                (install-file "tractor/tractor.gschema.xml" schemas)))))))
     (home-page "https://framagit.org/tractor")
     (synopsis "Setup an onion routing proxy")
     (description