summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-08-07 17:08:33 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 23:25:58 +0200
commit8205fe4493678cc38a95e2db8d8fcbca03b7173f (patch)
tree34dbd5d983dcc3dd742721b2a76e5c5075aaaf38
parent899784fb2184edc188efd638f41d7728d5fad962 (diff)
downloadguix-8205fe4493678cc38a95e2db8d8fcbca03b7173f.tar.gz
gnu: Add liblouisutdml.
* gnu/packages/language.scm (liblouisutdml): New variable.
* gnu/packages/patches/liblouisutdml-fix-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/language.scm52
-rw-r--r--gnu/packages/patches/liblouisutdml-fix-tests.patch33
3 files changed, 85 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7e2f1003bb..2174393f76 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1218,6 +1218,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/libgnomeui-utf8.patch			\
   %D%/packages/patches/libjxr-fix-function-signature.patch	\
   %D%/packages/patches/libjxr-fix-typos.patch			\
+  %D%/packages/patches/liblouisutdml-fix-tests.patch		\
   %D%/packages/patches/libofa-ftbfs-1.diff		\
   %D%/packages/patches/libofa-curl.diff		\
   %D%/packages/patches/libofa-ftbfs-2.diff		\
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 771df61497..4959f96a19 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -25,6 +25,7 @@
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
+  #:use-module (gnu packages java)
   #:use-module (gnu packages llvm)
   #:use-module (gnu packages man)
   #:use-module (gnu packages ocr)
@@ -35,6 +36,7 @@
   #:use-module (gnu packages swig)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages web)
+  #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (guix packages)
   #:use-module (guix build-system gnu)
@@ -42,7 +44,7 @@
   #:use-module (guix build-system python)
   #:use-module ((guix licenses)
                 #:select
-                (bsd-3 gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ perl-license zpl2.1))
+                (bsd-3 gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+ perl-license zpl2.1))
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix utils))
@@ -105,6 +107,54 @@ Marburg.")
       ;; Tools
       gpl3+))))
 
+(define-public liblouisutdml
+  (package
+    (name "liblouisutdml")
+    (version "2.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/liblouis/liblouisutdml.git")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11xxky3crjm8bidfljzpqaz1m1i1m1yskmdpavf9b4jpf87nzjj2"))
+       (patches
+        (search-patches "liblouisutdml-fix-tests.patch"))))
+    (build-system gnu-build-system)
+    (outputs '("out" "bin" "doc"))
+    (arguments
+     `(#:configure-flags
+       (list
+        "--disable-static")))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("help2man" ,help2man)
+       ("jdk" ,icedtea "jdk")
+       ("libtool" ,libtool)
+       ("makeinfo" ,texinfo)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxml2" ,libxml2)))
+    (propagated-inputs
+     `(("liblouis" ,liblouis)
+       ("liblouis:bin" ,liblouis "bin")))
+    (synopsis "Braille transcription services")
+    (description "Liblouisutdml is a library providing complete braille
+transcription services for xml, html and text documents.  It translates into
+appropriate braille codes and formats according to its style sheet and the
+specifications in the document.")
+    (home-page "http://liblouis.org/")
+    (license
+     (list
+      ;; Library
+      lgpl3+
+      ;; Tools
+      gpl3+))))
+
 (define-public libstemmer
   (package
     (name "libstemmer")
diff --git a/gnu/packages/patches/liblouisutdml-fix-tests.patch b/gnu/packages/patches/liblouisutdml-fix-tests.patch
new file mode 100644
index 0000000000..08d3db2c21
--- /dev/null
+++ b/gnu/packages/patches/liblouisutdml-fix-tests.patch
@@ -0,0 +1,33 @@
+From 52d44cdbc307d4e2ffc3ebe674745eb9d43ec337 Mon Sep 17 00:00:00 2001
+From: Christian Egli <christian.egli@sbs.ch>
+Date: Mon, 10 Aug 2020 16:08:17 +0200
+Subject: [PATCH] Some math over and under tests now actually pass
+
+with the newest liblouis
+---
+ tests/Makefile.am | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 157b005..932a5d0 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -321,10 +321,6 @@ XFAIL_TESTS +=					\
+ 	mathml_nemeth/mover_06.test		\
+ 	mathml_nemeth/mover_07.test		\
+ 	mathml_nemeth/mover_08.test		\
+-	mathml_nemeth/mover_09.test		\
+-	mathml_nemeth/mover_10.test		\
+-	mathml_nemeth/mover_11.test		\
+-	mathml_nemeth/mover_12.test		\
+ 	mathml_nemeth/mover_13.test		\
+ 	mathml_nemeth/mover_14.test		\
+ 	mathml_nemeth/mover_15.test		\
+@@ -332,7 +328,6 @@ XFAIL_TESTS +=					\
+ 	mathml_nemeth/munder_01.test		\
+ 	mathml_nemeth/munder_02.test		\
+ 	mathml_nemeth/munder_03.test		\
+-	mathml_nemeth/munder_04.test		\
+ 	mathml_nemeth/munder_05.test		\
+ 	mathml_nemeth/munder_06.test		\
+ 	mathml_nemeth/munder_07.test		\