summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-03 19:33:47 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-12 23:49:02 +0100
commit856e3f9cb4dc3bc9c13a06f20d84df70e11213a3 (patch)
tree1b95223f686ca11f79481f1093a1a12b8155f074
parentfd11c0fd3df2988831a3aedf136eda211aa69150 (diff)
downloadguix-856e3f9cb4dc3bc9c13a06f20d84df70e11213a3.tar.gz
gnu: KDE Plasma: Update to 5.14.5.
* gnu/packages/kde-plasma.scm (libkscreen): Update to 5.14.5.
(libksysguard): Likewise.
[inputs]: Add KGLOBALACCEL and KIO.
-rw-r--r--gnu/packages/kde-plasma.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index bed9cc09bc..ff6fa64a17 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -32,14 +32,14 @@
 (define-public libkscreen
   (package
     (name "libkscreen")
-    (version "5.13.5")
+    (version "5.14.5")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://kde/stable/plasma/" version "/"
                            name "-" version ".tar.xz"))
        (sha256
-        (base32 "04719va15i66qn1xqx318v6risxhp8bfcnhxh9mqm5h9qx5c6c4k"))))
+        (base32 "1vyaml5ap9siw9idiny92li2bykd0nwjsmwmg0c7ad912j4g1s7y"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
@@ -71,7 +71,7 @@ basic needs and easy to configure for those who want special setups.")
 (define-public libksysguard
   (package
     (name "libksysguard")
-    (version "5.13.4")
+    (version "5.14.5")
     (source
      (origin
        (method url-fetch)
@@ -79,7 +79,7 @@ basic needs and easy to configure for those who want special setups.")
                            "/libksysguard-" version ".tar.xz"))
        (sha256
         (base32
-         "0k8q5bxk9zyv7c3nny1c399v8acqs618nw39q20pj2qdijl9ibvh"))))
+         "11nz0g7dqvpvgsv0a7sai445vgfsfi25plj7jb1i46n7zf8i8mya"))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
@@ -92,6 +92,8 @@ basic needs and easy to configure for those who want special setups.")
        ("kcompletion" ,kcompletion)
        ("kconfig" ,kconfig)
        ("kcoreaddons" ,kcoreaddons)
+       ("kglobalaccel" ,kglobalaccel)
+       ("kio" ,kio)
        ("kwidgetsaddons" ,kwidgetsaddons)
        ("kservice" ,kservice)
        ("qtbase" ,qtbase)