summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-13 16:41:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-13 16:47:22 +0100
commit8ae17933e2bdffe21351cfa664ac9773125c674b (patch)
tree8f35e922253ea03ceb35a9dfc013fec69884253f
parentd81fb2ae9443994ae5dd1cb5837276fad63f842c (diff)
downloadguix-8ae17933e2bdffe21351cfa664ac9773125c674b.tar.gz
gnu: opensubdiv: Build with a newer version of Mesa.
* gnu/packages/gl.scm (mesa-19.3.3): New public variable.
* gnu/packages/graphics.scm (opensubdiv)[inputs]: Add it.
-rw-r--r--gnu/packages/gl.scm19
-rw-r--r--gnu/packages/graphics.scm7
2 files changed, 24 insertions, 2 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d0718d5d45..e610fe1dd7 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -11,6 +11,7 @@
 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -422,6 +423,24 @@ device drivers allows Mesa to be used in many different environments ranging
 from software emulation to complete hardware acceleration for modern GPUs.")
     (license license:x11)))
 
+;; Mesa 19.3.2 causes a test failure in some packages, so add this newer
+;; version separately until the next rebuild cycle.
+(define-public mesa-19.3.3
+  (package/inherit
+   mesa
+   (version "19.3.3")
+   (source (origin
+             (inherit (package-source mesa))
+             (uri (list (string-append "https://mesa.freedesktop.org/archive/"
+                                       "mesa-" version ".tar.xz")
+                        (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+                                       "mesa-" version ".tar.xz")
+                        (string-append "ftp://ftp.freedesktop.org/pub/mesa/"
+                                       version "/mesa-" version ".tar.xz")))
+             (sha256
+              (base32
+               "02czqdqf64i3az5p1allnxycyjad3x35cj0hz0017mi5pc84ikl1"))))))
+
 (define-public mesa-opencl
   (package
     (inherit mesa)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 4b6e57986c..bcdc372d86 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -16,7 +16,7 @@
 ;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
 ;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -1061,7 +1061,10 @@ requirements.")
     (native-inputs
      `(("xorg-server" ,xorg-server-for-tests)))
     (inputs
-     `(("glew" ,glew)
+     `(;; The test suite fails when using Mesa 19.3.2, so we provide this newer
+       ;; version.  Remove this input when the 'mesa' package is updated.
+       ("mesa" ,mesa-19.3.3)
+       ("glew" ,glew)
        ("libxrandr" ,libxrandr)
        ("libxcursor" ,libxcursor)
        ("libxinerama" ,libxinerama)