summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-22 22:11:03 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-22 22:11:37 +0100
commit8b16a5e1996bd9ec66915f84beaac6d34cb0f353 (patch)
treead8b3969d6dbbc91b2c15c6fe3cb7db3d883a595
parentb0fef4d660ca86fdda5749356fbc29a456e7a326 (diff)
downloadguix-8b16a5e1996bd9ec66915f84beaac6d34cb0f353.tar.gz
gnu: pkg-config: Add non-HTTPS alternate URL.
* gnu/packages/pkg-config.scm (%pkg-config)[source]: Add non-HTTPS URL.
-rw-r--r--gnu/packages/pkg-config.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/pkg-config.scm b/gnu/packages/pkg-config.scm
index 5923395dec..d7cc454e03 100644
--- a/gnu/packages/pkg-config.scm
+++ b/gnu/packages/pkg-config.scm
@@ -33,9 +33,17 @@
    (version "0.29")
    (source (origin
             (method url-fetch)
-            (uri (string-append
-                  "http://pkgconfig.freedesktop.org/releases/pkg-config-"
-                  version ".tar.gz"))
+            (uri (list
+                  (string-append
+                   "http://fossies.org/linux/misc/pkg-config-" version
+                   ".tar.gz")
+
+                  ;; FIXME: The following URL redirects to HTTPS, which
+                  ;; creates bootstrapping problems:
+                  ;; <http://bugs.gnu.org/22774>.
+                  (string-append
+                   "http://pkgconfig.freedesktop.org/releases/pkg-config-"
+                   version ".tar.gz")))
             (sha256
              (base32
               "0sq09a39wj4cxf8l2jvkq067g08ywfma4v6nhprnf351s82pfl68"))))