summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-10-09 02:30:54 +0200
committerMarius Bakke <marius@gnu.org>2021-10-11 18:59:44 +0200
commit9015a9a906f487bdedcbe028be023e8bee611c5a (patch)
tree5e861077f896bf2c7e6d83703d63b6f6751c0bb1
parent601d9972de5bc25dc522bd59f5547bacd4d5678b (diff)
downloadguix-9015a9a906f487bdedcbe028be023e8bee611c5a.tar.gz
gnu: drbd-utils: Update to 9.19.0.
* gnu/packages/cluster.scm (drbd-utils): Update to 9.19.0.
[source](uri): Update for new download location.
[source](snippet): Adjust faulty substitution.
[arguments]: Add #:make-flags.
-rw-r--r--gnu/packages/cluster.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 2de5f6fe36..eef6527f6f 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -42,26 +42,21 @@
 (define-public drbd-utils
   (package
     (name "drbd-utils")
-    (version "9.15.1")
+    (version "9.19.0")
     (source (origin
               (method url-fetch)
-              ;; Older releases are moved to /archive.  List it first because in
-              ;; practice this URL will be the most current (e.g. time-machine).
-              (uri (list (string-append "https://www.linbit.com/downloads/drbd"
-                                        "/utils/archive/drbd-utils-" version
-                                        ".tar.gz")
-                         (string-append "https://www.linbit.com/downloads/drbd"
+              (uri (list (string-append "https://pkg.linbit.com/downloads/drbd"
                                         "/utils/drbd-utils-" version ".tar.gz")))
               (sha256
                (base32
-                "1q92bwnprqkkj9iy6fxcybcfpxvvjw5clis0igrbxqnq869kwp1i"))
+                "1bbw91hil55d2047r2bdhx2daxc1wqysra2qqm77iy1hcvnvy9rq"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   (substitute* "scripts/global_common.conf"
                     ;; Do not participate in usage count survey by default.
-                    (("usage-count: yes")
-                     "usage-count: no"))
+                    (("usage-count yes")
+                     "usage-count no"))
                   (substitute* "scripts/Makefile.in"
                     ;; Install the Pacemaker resource agents to the libdir,
                     ;; regardless of what the OCF specification says...
@@ -86,6 +81,7 @@
                            "--sysconfdir=/etc"
                            "--localstatedir=/var")
        #:test-target "test"
+       #:make-flags '("WANT_DRBD_REPRODUCIBLE_BUILD=yesplease")
        #:phases
        (modify-phases %standard-phases
          (add-after 'patch-generated-file-shebangs 'patch-documentation