summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-21 16:15:03 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-21 16:22:51 +0200
commit9834ff5d3293b2af728b41314c18ca7fb2081efe (patch)
tree6796820698ff7207b1ba72f0a48d094a18791039
parent49546b6b8c662d8b02b1d1671004e3c24a674b8a (diff)
downloadguix-9834ff5d3293b2af728b41314c18ca7fb2081efe.tar.gz
gnu: binutils-gold: Skip gold testsuite on some architectures.
* gnu/packages/base.scm (binutils-gold)[arguments]: Add a phase on some
architecturest to skip the gold testsuite.
-rw-r--r--gnu/packages/base.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index dd590575a4..12e4de52d4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -606,7 +606,15 @@ included.")
            (add-after 'patch-source-shebangs 'patch-more-shebangs
              (lambda _
                (substitute* "gold/Makefile.in"
-                 (("/bin/sh") (which "sh")))))))))
+                 (("/bin/sh") (which "sh")))))
+           ;; Multiple failing tests on some architectures in the gold testsuite.
+           ,@(if (or (target-arm?)
+                     (target-ppc32?))
+               '((add-after 'unpack 'skip-gold-testsuite
+                   (lambda _
+                     (substitute* "gold/Makefile.in"
+                       ((" testsuite") " ")))))
+               '())))))
     (native-inputs
      `(("bc" ,bc)))))