summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-02-04 13:48:18 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-04 21:41:46 +0100
commit99b030c7052abb5bc80c7e2e892529f0de8e4bf2 (patch)
treeb88f9121fc99d7dc4291b3f66d8dac9f9591c17b
parent7c9325a9ecad1a8d02793aadb2e1730b4a8de48b (diff)
downloadguix-99b030c7052abb5bc80c7e2e892529f0de8e4bf2.tar.gz
gnu: gxmessage: New module
* gnu/packages/gxmessage.scm: New file
* gnu-system.am (GNU_SYSTEM_MODULES): Add gxmessage.scm

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/gxmessage.scm50
2 files changed, 51 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 1f7327e865..0a9fb4651e 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -101,6 +101,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/guile.scm			\
   gnu/packages/guile-wm.scm			\
   gnu/packages/gv.scm				\
+  gnu/packages/gxmessage.scm			\
   gnu/packages/help2man.scm			\
   gnu/packages/hugs.scm				\
   gnu/packages/icu4c.scm			\
diff --git a/gnu/packages/gxmessage.scm b/gnu/packages/gxmessage.scm
new file mode 100644
index 0000000000..425659274c
--- /dev/null
+++ b/gnu/packages/gxmessage.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages gxmessage)
+  #:use-module (guix licenses)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages))
+
+(define-public gxmessage
+  (package
+    (name "gxmessage")
+    (version "2.20.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
+                                 version ".tar.gz"))
+             (sha256
+              (base32 "1nq8r321x3rzcdkjlvj61i9x7smslnis7b05b39xqcjc9xyg4hv0"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gtk+" ,gtk+-2)))
+    (native-inputs
+     `(("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)))
+    (home-page "http://www.gnu.org/software/gxmessage/")
+    (synopsis "Open popup message window with buttons for return")
+    (description "GNU gxmessage is a program that pops up dialog windows, which display
+a message to the user and waits for their action.  The program then exits
+with an exit code corresponding to the response.")
+    (license gpl3+)))