summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-27 05:23:34 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-09-05 10:26:28 -0400
commita06a36401eddf4c28402cd53eeeb2a888885b57c (patch)
treef069dd5d282c08375c942d1dd1c4068951683db0
parent4bd9198abf279fb72f56b825246ea2aaf7847cc6 (diff)
downloadguix-a06a36401eddf4c28402cd53eeeb2a888885b57c.tar.gz
gnu: python-pygobject: Update to 3.40.1.
* gnu/packages/glib.scm (python-pygobject)[version]: Update to 3.40.1.
[native-inputs]: Add python-wrapper.
-rw-r--r--gnu/packages/glib.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 5fb266c555..330011418c 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -776,7 +776,7 @@ useful for C++.")
 (define-public python-pygobject
   (package
     (name "python-pygobject")
-    (version "3.34.0")
+    (version "3.40.1")
     (source
      (origin
        (method url-fetch)
@@ -785,7 +785,7 @@ useful for C++.")
                            "/pygobject-" version ".tar.xz"))
        (sha256
         (base32
-         "06i7ynnbvgpz0gw09zsjbvhgcp5qz4yzdifw27qjwdazg2mckql7"))
+         "0d80g5kgf2i9cginyhalvb7ibfk9g30yilqzmcsw6h6byj8xbih0"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -800,7 +800,8 @@ useful for C++.")
     (native-inputs
      `(("glib-bin" ,glib "bin")
        ("pkg-config" ,pkg-config)
-       ("python-pytest" ,python-pytest)))
+       ("python-pytest" ,python-pytest)
+       ("python-wrapper" ,python-wrapper))) ; For patching shebangs
     (inputs
      `(("python" ,python)
        ("python-pycairo" ,python-pycairo)