summary refs log tree commit diff
diff options
context:
space:
mode:
authorAmar Singh <nly@disroot.org>2020-12-24 21:28:06 +0530
committer宋文武 <iyzsong@member.fsf.org>2021-02-16 18:07:34 +0800
commita3be53efb6245120ca7f4b26535a11b88750a4f1 (patch)
tree82308b8685f2c60ad146f8cc8199512a81ce71b4
parent1535c07e92bb52ca207d5915dfe141e5acac2528 (diff)
downloadguix-a3be53efb6245120ca7f4b26535a11b88750a4f1.tar.gz
gnu: i2pd: Update to 2.36.0.
* gnu/packages/i2p.scm (i2pd): Update to 2.36.0.
[arguments]: Enable the 'x25519' test.  Remove 'install-headers'
and 'remove-source' phases.

Co-authored-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/i2p.scm34
1 files changed, 4 insertions, 30 deletions
diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index 537aeaf76c..5698e6362c 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -30,7 +30,7 @@
 (define-public i2pd
   (package
     (name "i2pd")
-    (version "2.31.0")
+    (version "2.36.0")
     (source
      (origin
        (method git-fetch)
@@ -39,7 +39,7 @@
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1q2gxz041ha9n5lfn91iy11sdf3z7d806vcq4z43m7lf92m7i4nn"))))
+        (base32 "0gx7y0vrg9lsl7m1r6c8xyyqmaqn900kms4g0941g0gd5zdb0mvz"))))
     (build-system cmake-build-system)
     (inputs `(("boost" ,boost)
               ("miniupnpc" ,miniupnpc)
@@ -66,39 +66,13 @@
                                            "./tests")
                          (with-directory-excursion "tests"
                            (substitute* "Makefile"
-                             (("../libi2pd/") (string-append source "/libi2pd/"))
-                             ;; Disable the x25519 test, which only compiles if
-                             ;; openssl doesn't have X25519 support, but the
-                             ;; version we use has it.
-                             (("test-base-64 test-x25519 test-aeadchacha20poly1305")
-                              "test-base-64 test-aeadchacha20poly1305"))
+                             (("../libi2pd/") (string-append source "/libi2pd/")))
                            (apply invoke "make" "all"
                                   `(,@(if parallel-tests?
                                           `("-j" ,(number->string
                                                     (parallel-job-count)))
                                           '())
-                                    ,@make-flags))))))
-                   (add-after 'install 'install-headers
-                     (lambda* (#:key outputs #:allow-other-keys)
-                       (let* ((install-dir (assoc-ref outputs "out"))
-                              (src-dir (string-append install-dir "/src"))
-                              (include-dir
-                               (string-append install-dir "/include")))
-                         (mkdir-p include-dir)
-                         ;; This is the only header file that's relevant to the
-                         ;; public interface.
-                         ;; <https://github.com/PurpleI2P/i2pd/issues/1378>
-                         (install-file (string-append src-dir "/api.h")
-                                       include-dir)
-                         #t)))
-                   (add-after 'install-headers 'remove-source
-                     (lambda* (#:key outputs #:allow-other-keys)
-                       (let* ((install-dir (assoc-ref outputs "out"))
-                              (src-dir (string-append install-dir "/src")))
-                         (delete-file-recursively src-dir)
-                         (delete-file (string-append install-dir
-                                                     "/LICENSE"))
-                         #t))))))
+                                    ,@make-flags)))))))))
     (home-page "https://i2pd.website/")
     (synopsis "Router for an end-to-end encrypted and anonymous internet")
     (description "i2pd is a client for the anonymous I2P network, upon which