summary refs log tree commit diff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:06:48 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:14 +0200
commita68d52a000c0a0f5b103672aec1c00b626e41518 (patch)
tree9c2d2a73e706102f506029d6ad91821bdc91f38a
parent1817f5cf4b04d2f2104dcb1de0f0db578aa02b85 (diff)
downloadguix-a68d52a000c0a0f5b103672aec1c00b626e41518.tar.gz
gnu: Remove unneeded libxml2 from native-inputs. (libxslt)
XML_CATALOG_FILES is already set within libxslt so it's unnecessary to include
libxml2 for the same effect.

* gnu/packages/freedesktop.scm (wayland): Remove obsolete comment.
(farstream, elogind, packagekit, accountsservice, plymouth)[native-inputs]:
Remove libxml2.
* gnu/packages/benchmark.scm (sysbench)[native-inputs]: Ditto.
* gnu/packages/cluster.scm (drbd-utils)[native-inputs]: Ditto.
* gnu/packages/glib.scm (dbus)[native-inputs]: Ditto.
* gnu/packages/gnome.scm (gnome-keyring, glade3, dconf, libsecret, colord)
(upower, gnome-settings-daemon)[native-inputs]: Ditto.
* gnu/packages/linux.scm (eudev)[native-inputs]: Ditto.
* gnu/packages/networking.scm (iputils)[native-inputs]: Ditto.
* gnu/packages/ocr.scm (tesseract-ocr)[native-inputs]: Ditto.
* gnu/packages/polkit.scm (polkit)[native-inputs]: Ditto.
* gnu/packages/samba.scm (samba/pinned)[native-inputs]: Ditto.
* gnu/packages/sssd.scm (adcli)[native-inputs]: Ditto.
* gnu/packages/terminals.scm (kmscon)[native-inputs]: Ditto.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: Ica3fb5a8e23ad928c53ae508c02777d78c635af0
-rw-r--r--gnu/packages/benchmark.scm1
-rw-r--r--gnu/packages/cluster.scm1
-rw-r--r--gnu/packages/freedesktop.scm7
-rw-r--r--gnu/packages/glib.scm1
-rw-r--r--gnu/packages/gnome.scm9
-rw-r--r--gnu/packages/linux.scm1
-rw-r--r--gnu/packages/networking.scm4
-rw-r--r--gnu/packages/ocr.scm1
-rw-r--r--gnu/packages/polkit.scm1
-rw-r--r--gnu/packages/samba.scm3
-rw-r--r--gnu/packages/sssd.scm1
-rw-r--r--gnu/packages/terminals.scm1
12 files changed, 4 insertions, 27 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index bfc70c5d3d..1707403826 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -663,7 +663,6 @@ its features are:
                          python-wrapper
                          which
                          ;; For documentation
-                         libxml2        ;for XML_CATALOG_FILES
                          libxslt
                          docbook-xml
                          docbook-xsl))
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index f342d159e1..659b8282ab 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -139,7 +139,6 @@
                (list docbook-xml
                      docbook-xml-4.4            ;used by documentation/ra2refentry.xsl
                      docbook-xsl
-                     libxml2                    ;for XML_CATALOG_FILES
                      libxslt                    ;for xsltproc
                      ruby-asciidoctor)
                '())))
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 17ef8714ae..92937d626c 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -292,7 +292,6 @@ application-centers for distributions.")
            gobject-introspection
            gtk-doc/stable
            libtool
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            perl
            pkg-config
@@ -898,7 +897,6 @@ the freedesktop.org XDG Base Directory specification.")
            docbook-xsl
            gettext-minimal
            gperf
-           libxml2                      ;for XML_CATALOG_FILES
            m4
            pkg-config
            python
@@ -1129,7 +1127,6 @@ with localed.  This package is extracted from the broader systemd package.")
            gettext-minimal
            `(,glib "bin")
            gobject-introspection
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            pkg-config
            python-wrapper
@@ -1354,7 +1351,7 @@ Python.")
           (list pkg-config-for-build
                 this-package)           ;for wayland-scanner
           '())))
-    (inputs (list expat libxml2))       ;for XML_CATALOG_FILES
+    (inputs (list expat libxml2))
     (propagated-inputs (list libffi))
     (home-page "https://wayland.freedesktop.org/")
     (synopsis "Core Wayland window system code and protocol")
@@ -1863,7 +1860,6 @@ message bus.")
            glibc-locales                    ;for tests
            gobject-introspection
            gtk-doc
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            pkg-config
            vala
@@ -2760,7 +2756,6 @@ Its features include:
     (native-inputs
      (list gettext-minimal
            pkg-config
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            docbook-xsl
            docbook-xml))
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index f490005b2d..299187a664 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -161,7 +161,6 @@
            docbook-xsl
            doxygen
            libtool
-           libxml2 ;for XML_CATALOG_FILES
            libxslt
            which
            xmlto
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ed9dbcb90f..114166b10a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2671,7 +2671,6 @@ GNOME Desktop.")
            gettext-minimal
            `(,glib "bin")
            glib                         ;for m4 macros
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt                      ;for documentation
            pkg-config
            python-wrapper))             ;for tests
@@ -3296,7 +3295,6 @@ API add-ons to make GTK+ widgets OpenGL-capable.")
            gobject-introspection
            hicolor-icon-theme
            itstool
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt                      ;for xsltproc
            python
            python-pygobject
@@ -4776,7 +4774,6 @@ and RDP protocols.")
     (native-inputs
      (list bash-completion
            libxslt                      ;for xsltproc
-           libxml2                      ;for XML_CATALOG_FILES
            docbook-xml-4.2
            docbook-xsl
            `(,glib "bin")
@@ -5292,7 +5289,6 @@ and the GLib main loop, to integrate well with GNOME applications.")
            gettext-minimal
            `(,glib "bin")               ;for gdbus-codegen, etc.
            gobject-introspection
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            pkg-config
            python
@@ -5751,7 +5747,6 @@ output devices.")
        (append bash-completion
                docbook-xsl-1.79.1
                gtk-doc/stable
-               libxml2                  ;for XML_CATALOG_FILES
                libxslt
                sane-backends
                vala)))))                ;for VAPI, needed by simple-scan
@@ -5920,8 +5915,7 @@ faster results and to avoid unnecessary server load.")
            dbus
            ;; For man pages.
            docbook-xsl
-           libxslt                      ; for 'xsltproc'
-           libxml2))                    ; for 'XML_CATALOG_FILES'
+           libxslt))                    ; for 'xsltproc'
     (inputs
      (list libgudev libusb))
     (propagated-inputs
@@ -6094,7 +6088,6 @@ services for numerous locations.")
            docbook-xsl
            gettext-minimal
            `(,glib "bin")               ;for glib-mkenums
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            perl
            pkg-config))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ef2d2ba65e..3ba4a7e9e2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4510,7 +4510,6 @@ to the in-kernel OOM killer.")
            ;; For documentation.
            docbook-xml-4.2
            docbook-xsl
-           libxml2            ;for $XML_CATALOG_FILES
            libxslt))
     (inputs
      ;; When linked against libblkid, eudev can populate /dev/disk/by-label
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3ffe7659dd..e59696772c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1654,9 +1654,7 @@ intended as a substitute for the PPPStatus and EthStatus projects.")
                  "if false")))))))
     (native-inputs
      (list docbook-xsl docbook-xml-5.0.1
-           gettext-minimal
-           libxml2          ;for XML_CATALOG_FILES
-           libxslt pkg-config))
+           gettext-minimal libxslt pkg-config))
     (inputs
      (list libcap libidn2 openssl))
     (synopsis "Collection of network utilities")
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 089bea7f01..8e376da78b 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -160,7 +160,6 @@ models for the Tesseract OCR Engine.")
            libarchive
            libtiff
            libtool
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            pkg-config
            tesseract-ocr-tessdata-fast))
diff --git a/gnu/packages/polkit.scm b/gnu/packages/polkit.scm
index 58a8a236f7..883688a7af 100644
--- a/gnu/packages/polkit.scm
+++ b/gnu/packages/polkit.scm
@@ -153,7 +153,6 @@
            `(,glib "bin")               ;for glib-mkenums
            docbook-xsl                  ;for man page generation
            gobject-introspection
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt                      ;for man page generation
            perl
            pkg-config
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index f52b86e1ed..18acf52cbf 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -278,8 +278,7 @@ external dependencies.")
              ;; For generating man pages.
              docbook-xml-4.2
              docbook-xsl
-             libxslt
-             libxml2)))                 ;for XML_CATALOG_FILES
+             libxslt)))
      (home-page "https://www.samba.org/")
      (synopsis
       "The standard Windows interoperability suite of programs for GNU and Unix")
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm
index 306306e66f..6fb43195e7 100644
--- a/gnu/packages/sssd.scm
+++ b/gnu/packages/sssd.scm
@@ -92,7 +92,6 @@
            docbook-xml-4.3
            docbook-xsl
            libtool
-           libxml2                      ;for XML_CATALOG_FILES
            libxslt
            util-linux                   ;For `rev` command used in tests.
            xmlto))
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index e84c8e5b96..1fc29837b3 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -349,7 +349,6 @@ compatibility to existing emulators like xterm, gnome-terminal, konsole, etc.")
              automake
              libtool
              libxslt ;to build the man page
-             libxml2 ;for XML_CATALOG_FILES
              docbook-xsl))
       (inputs
        `(("libdrm" ,libdrm)