summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-23 19:16:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 19:17:33 +0300
commitaa246eaa6b338fc6509bd5e6b93fa23121b2c95c (patch)
tree4922c4562a3e945b23ed6bf17e3977b462c19865
parent9b03299544e540ad5975abb306c19eb0168aa5e1 (diff)
downloadguix-aa246eaa6b338fc6509bd5e6b93fa23121b2c95c.tar.gz
gnu: openmw: Don't use unstable tarball.
* gnu/packages/game-development.scm (openmw)[source]: Download using
git-fetch.
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7eabf46627..74ab51f8b3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1492,13 +1492,14 @@ of use.")
     (version "0.46.0")
     (source
      (origin
-       (method url-fetch)
-       (uri
-        (string-append "https://github.com/OpenMW/openmw/archive/"
-                       "openmw-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/OpenMW/openmw")
+              (commit (string-append "openmw-" version))))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "0n7x39kwhwmi6ly9hd7yc6dhlrmmdmx30ahc46kmlzzn2n7mm8q7"))))
+         "0rm32zsmxvr6b0jjihfj543skhicbw5kg6shjx312clhlm035w2x"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; No test target