summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-10 11:03:12 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:37 -0500
commitac6f6772496378893a8ebfce4bf1707aed2fe089 (patch)
tree5a4b9e6c32c2284ddda8acf43d41e5c7fe610e86
parent661b25a2ed090bd16f212cefd45296221a141afc (diff)
downloadguix-ac6f6772496378893a8ebfce4bf1707aed2fe089.tar.gz
gnu: Add binutils-next.
* gnu/packages/base.scm (binutils-next): New variable.
-rw-r--r--gnu/packages/base.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 41641c7ffa..c2db2f0b1d 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -558,6 +558,23 @@ included.")
    (license gpl3+)
    (home-page "https://www.gnu.org/software/binutils/")))
 
+;;; TODO: Merge into binutils on the next world rebuild.
+(define-public binutils-next
+  (package/inherit binutils
+    (name "binutils-next")
+    (version "2.37")
+    (arguments
+     (substitute-keyword-arguments (package-arguments binutils)
+       ((#:out-of-source? _ #f)         ;recommended in the README
+        #t)
+       ((#:configure-flags flags)
+        `(cons* "--enable-64-bit-bfd"
+                "--enable-compressed-debug-sections=all"
+                "--enable-lto"
+                "--enable-separate-code"
+                "--enable-threads"
+                ,flags))))))
+
 ;; FIXME: ath9k-firmware-htc-binutils.patch do not apply on 2.34 because of a
 ;; big refactoring of xtensa-modules.c (commit 567607c11fbf7105 upstream).
 ;; Keep this version around until the patch is updated.