summary refs log tree commit diff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-05-31 19:27:01 +0000
committerLudovic Courtès <ludo@gnu.org>2023-06-24 17:00:01 +0200
commitaea081e87d4a6b7f1cebbea6fd37115389b14648 (patch)
treeb60070494067bd2ddd6f38b8be1d6722d705b0fe
parent5338f5eec0f94dd2b38938cafe8a71867c90c594 (diff)
downloadguix-aea081e87d4a6b7f1cebbea6fd37115389b14648.tar.gz
gnu: Add subunit.
* gnu/packages/check.scm (subunit): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/check.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 87728fefa3..4acac531c2 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3554,3 +3554,36 @@ with SRFI 64-based test suites.  It comes with a command-line interface
 to run test collections, and a library that includes a test runner and
 helpers for writing tests.")
     (license license:public-domain)))
+
+(define-public subunit
+  (package
+    (name "subunit")
+    (version "1.4.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/testing-cabal/subunit")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "16n1zxwnmhb7vzixngvmm5zzk4q5jaqqjwyr6pr6w0ys60b7xja3"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf
+                         automake
+                         check
+                         cppunit
+                         libtool
+                         pkg-config
+                         python-fixtures
+                         python-hypothesis
+                         python-testscenarios))
+    (inputs (list perl python))
+    (propagated-inputs (list python-testtools))
+    (home-page "https://github.com/testing-cabal/subunit")
+    (synopsis "Test reporting and control protocol")
+    (description
+     "Subunit is a streaming protocol for test results.  Subunit comes with
+command line filters to process a subunit stream and language bindings for
+Python, C, C++ and shell.  Bindings are easy to write for other languages.")
+    (license (list license:asl2.0 license:bsd-3)))) ;user can pick