summary refs log tree commit diff
diff options
context:
space:
mode:
authorLilah Tascheter <lilah@lunabee.space>2022-08-27 18:37:55 -0500
committerLudovic Courtès <ludo@gnu.org>2022-09-08 16:22:22 +0200
commitb2e560aca4f6bbd0d43ae5c821f4add6e47da801 (patch)
treed4ed66fc2f7187b1809d4334149aa46700c3ce5e
parent4ace4692c09ec65a5be7968b44ebd6e42a9c3b32 (diff)
downloadguix-b2e560aca4f6bbd0d43ae5c821f4add6e47da801.tar.gz
gnu: man-pages: Update to new style.
* gnu/packages/man.scm (man-pages)[arguments]: Refer to package output
  using gexps instead of assoc-ref on a parameter.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/man.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index f1e9a7aa78..50796df89e 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -282,7 +282,7 @@ PostScript, and PDF.  Additional tools include the @command{man} viewer, and
         (base32 "12vb15gs56g8wl5nqlm4llr508brh4m2lfknhq4lizbxzqzawkb1"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases (delete 'configure))
+     `(#:phases (modify-phases %standard-phases (delete 'configure))
 
        ;; The 'all' target depends on three targets that directly populate
        ;; $(MANDIR) based on its current contents.  Doing that in parallel
@@ -290,9 +290,7 @@ PostScript, and PDF.  Additional tools include the @command{man} viewer, and
        #:parallel-build? #f
 
        #:tests? #f
-       #:make-flags (list (string-append "mandir="
-                                         (assoc-ref %outputs "out")
-                                         "/share/man"))))
+       #:make-flags ,#~(list (string-append "mandir=" #$output "/share/man"))))
     (home-page "https://www.kernel.org/doc/man-pages/")
     (synopsis "Development manual pages from the Linux project")
     (description