summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-06-16 00:53:11 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-06-17 21:29:07 +0530
commitb4eae997fe5b928f179c34d281e9f2c3eccd3670 (patch)
tree608603a69c09a16bd700463f15a6b3dfdf4518d3
parent33f61dc1b5e14f8a2e3dfb3fb48102bda0fd6b13 (diff)
downloadguix-b4eae997fe5b928f179c34d281e9f2c3eccd3670.tar.gz
gnu: texlive-bin: Use absolute path to ghostscript executable "gs".
* gnu/packages/tex.scm (texlive-bin)[arguments]: Rename fix-unix-detection
phase to configure-ghostscript-executable. Replace "gs" in epstopdf.pl with
the absolute path to "gs" in the store.
-rw-r--r--gnu/packages/tex.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b6bc9dda62..b290644aac 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -176,14 +176,17 @@
                            (string-prefix? "mips64" s))))
       #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'fix-unix-detection
+         (add-after 'unpack 'configure-ghostscript-executable
            ;; ps2eps.pl uses the "gswin32c" ghostscript executable on Windows,
            ;; and the "gs" ghostscript executable on Unix. It detects Unix by
            ;; checking for the existence of the /usr/bin directory. Since
            ;; GuixSD does not have /usr/bin, it is also detected as Windows.
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "utils/ps2eps/ps2eps-src/bin/ps2eps.pl"
                (("gswin32c") "gs"))
+             (substitute* "texk/texlive/linked_scripts/epstopdf/epstopdf.pl"
+               (("\"gs\"")
+                (string-append "\"" (assoc-ref inputs "ghostscript") "/bin/gs\"")))
              #t))
          (add-after 'install 'postint
            (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)